Eigene CSS Regeln einbinden

Mehr
4 Monate 3 Tage her - 4 Monate 3 Tage her #4789 von Raimoon

Mit dem Allrounder 4 gibt es zwei Wege wie man eigene CSS Regeln einbinden kann:
  • Im Templatestil in den Einstellungen gibt es ein Textfeld "Benutzerdefinierte CSS Regeln".
  • Als Datei /media/templates/site/allrounder/css/user.css
Beide Varianten sind "updatesicher", bleiben also bei einem Update des Templates bestehen.
 

Hallo Thomas, das Media-Verzeichnis ist jetzt vorhanden aber die user.css lässt sich nicht in deinem angegebenen Verzeichnis erstellen. Es wird im ersten Verzeichnis erstellt und somit wirkungslos. 
Gruß Rainer

 
Letzte Änderung: 4 Monate 3 Tage her von Thomas Hunziker.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 3 Tage her #4793 von Thomas Hunziker
Kannst du bitte mit der Version 4.0.2 nochmal testen? Bei mir funktioniert es nun auch auf Linux.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 3 Tage her #4795 von Raimoon

Kannst du bitte mit der Version 4.0.2 nochmal testen? Bei mir funktioniert es nun auch auf Linux.

Es funktioniert noch nicht.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 2 Tage her #4796 von Jochen Ebert
Ich habe mir im Verzeichnis die Datei per Hand angelegt und dort meine Sachen abgelegt, funktioniert.

Was allerdings nicht funktionierte ist folgendes:
In meine user.css steht folgendes

#header {
background-image: url("/images/webserver/homepage/hintergrund.jpeg");
background-size: cover;
}

.footer-bottom span#date {
font-size: 12px;
color: #76a4e8
}

Das funktioniert einwandfrei.

Wenn ich nun aber noch
.nav a:hover {
text-decoration: none;
}
am Ende einfüge, wird dieses nicht berücksichtigt.
Wenn ich es im Template allerdings eintrage funktioniert es.

Dieses wird aber bestimmt an meinen fehlenden Kenntnissen liegen. Mein Eintrag hat bestimmt einen falschen Bezug.

Gruß
Jochen

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 2 Tage her - 4 Monate 2 Tage her #4798 von Jochen Ebert

Kannst du bitte mit der Version 4.0.2 nochmal testen? Bei mir funktioniert es nun auch auf Linux.

Es funktioniert noch nicht.

 

Mit der 4.0.2 konnte ich über das "Templates: Anpassen (Allrounder)" eine Datei im Ordner /media/templates/site/allrounder/css/ (test.css) erstellen, beschreiben und auch wieder löschen..
Sind die Berechtigungen vielleicht nicht korrekt?
Anhänge:
Letzte Änderung: 4 Monate 2 Tage her von Jochen Ebert.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 2 Tage her #4799 von Thomas Hunziker

Wenn ich nun aber noch
.nav a:hover {
text-decoration: none;
}
am Ende einfüge, wird dieses nicht berücksichtigt.
Wenn ich es im Template allerdings eintrage funktioniert es.

Dein Browser hatte die CSS Datei vermutlich noch im Cache gespeichert. Das ist grundsätzlich ein Unterschied zwischen der Datei und dem Parameter im Stil. Die Datei kann im Cache gespeichert werden und wird dann nicht jedesmal vom Server geladen. Der Stil-Parameter wird im HTML Dokument dann direkt integriert und wird damit viel weniger gecachet.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.124 Sekunden
Powered by Kunena Forum
   
© Bakual