Komisches Verhalten der Dropdown Menüs in 2.0

Mehr
7 Jahre 6 Monate her #483 von nru
Bin leider doch noch nicht ganz durch. Hatte zwar den Downgrade auf 1.0 vorgenommen und die Sache mit Menüanzeige ist jetzt nach wie vor ok, aber irgendwie scheints immer noch zu hängen. Denn im Backend bekomm ich an einer Stelle einen Scriptfehler, (antwortet nicht), der ebenfalls mit 2x geladenem jQuery zu tun hat.

Hier im Thread wurde ja schonmal gefragt, wie man herausbekommen kann, wer alles jQuery lädt? Das würde mich auch sehr interessieren! Und die Geschichte mit der Reihenfolge wäre auch klasse.

Sorry, ich weiss, dass das nicht unbedingt Template-bedingte Fragen sind, aber ich brauch einfach etwas Input (am Wochenende sollte die Site online gehen) und wüsste a.) nicht wen sonst fragen könnte und b.) bekam ich hier immer klasse Feedback ;)

Mein Grundproblem: doppelte geladene jquery.min.js :(

Großes Dankeschön!

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Jahre 6 Monate her #484 von Thomas Hunziker
Also im Backend sollte der Fehler zumindest nicht im Zusammenhang mit diesem Template sein. Egal ob 1.x oder 2.x, das LessAllrounder macht da nix.

Hier im Thread wurde ja schonmal gefragt, wie man herausbekommen kann, wer alles jQuery lädt? Das würde mich auch sehr interessieren! Und die Geschichte mit der Reihenfolge wäre auch klasse.


Die einfachste Methode ist, ne Reihe Module und Plugins zu deaktivieren. Wenns dann weg ist, kannst du anfangen eines anch dem anderen wieder einzuschalten und zu gucken welches Schuld ist.
Am interessantesten sind die System und Content Plugins und Module.

Die Reihenfolge hängt bei den Modulen primär von der Modulposition ab, bei den Plugins von der Gruppe. Viel machen kannst du da nicht wirklich.
Folgende Benutzer bedankten sich: nru

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Bernhard
  • Besucher
  • Besucher
7 Jahre 6 Monate her #485 von Bernhard
Ich hoffe ich habs jetzt auch bereinigt, war wohl ein QR-Code Modul :evil:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Jahre 6 Monate her #486 von Thomas Hunziker
Wenn du magst, kannst du das Modul hier hochladen und ich guck kurz drüber ob mans einfach flicken kann.
Folgende Benutzer bedankten sich: Bernhard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Jahre 6 Monate her - 7 Jahre 6 Monate her #487 von nru
Zwischenstand: Ich hab jetzt sämltiche Plugins aus System und Content bis auf JSN PowerAdmin deaktiviert. Alle anderen. Fehler bleibt beim Aufruf des PowerAdmin SiteManagers :/
Jetzt gehts mal in den Bereich Module.

EDIT: _Alle_ Module deaktiviert!
Ein Skript auf dieser Seite ist eventuell beschäftigt oder es antwortet nicht mehr. Sie können das Skript jetzt stoppen oder fortsetzen, um zu sehen, ob das Skript fertig wird.
Skript: /plugins/system/jsnframework/assets/3rd-party/jquery/jquery.min.js:2

und im Quelltext finde ich dann
<script src="/plugins/system/jsnframework/assets/3rd-party/jquery/jquery.min.js" type="text/javascript"></script>
und etwas weiter unten
<script src="/media/jui/js/jquery.min.js" type="text/javascript"></script>

Sind natürlich unterschiedliche Versionen :(

Das raubt mir noch den Verstand :blink:
Letzte Änderung: 7 Jahre 6 Monate her von nru.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Jahre 6 Monate her #488 von Thomas Hunziker
Das Problem wird 150% vom JSN PowerAdmin verursacht. Der Pfad zum jQuery beinhaltet "jsnframework" was dazu gehören dürfte.
Ich würd mal bei dem Entwickler nachfragen und auch gucken ob sie nicht ne aktualisierte Version haben.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.196 Sekunden
Powered by Kunena Forum
   
© Bakual