Hintergrundfarbe Hauptmenüpunkte

Mehr
7 Jahre 1 Tag her - 7 Jahre 1 Tag her #1257 von Hotzenplotz
Hallo,

ich habe eine Seite aufgebaut (Stand noch Joomla 2.5 mit dem Allrounder-Template). Jetzt habe ich testweise das Upgrade gemacht und das Less-Allrounder-Template hier gefunden, was ich gerne weiter nutzen würde...

Das Template habe ich auch schon installiert: www.stroehl.com/ulfalux3

Außerdem würde ich gerne die Oberpunkte unter Produktion (also z.B. Ausbesserung für Fassaden, Spraydosenfertigung, ...) in jeweils einer anderen Hintergrundfarbe machen.

Da ich mich mit CSS leider so gut wie gar nicht auskenne, wird das für mich schon zu einer echten Herkulesaufgabe.

Die Original-Seite liegt unter ulfalux.de, dort kann man das mit den Farben sehen (läuft noch unter Joomla 1.5 :( ).
Joomla mit Allrounder in der Version 2.5 liegt hier: www.stroehl.com/ulfalux1 .
So hätte ich es gerne auch wieder von der Schriftgröße etc.
Leider habe ich den Fehler gemacht und ein paar Sachen im CSS angepasst, diese Änderungen aber direkt in die Original-Dateien geschrieben (weil ich es damals nicht besser wusste) und jetzt muss ich wohl das mühseelig wieder raussuchen.

Wäre toll, wenn mir jemand helfen könnte :) .

Viele Grüße
Hotzenplotz
Letzte Änderung: 7 Jahre 1 Tag her von Hotzenplotz.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Jahre 1 Tag her #1258 von Thomas Hunziker
Wenn jeder Menüpunkt ne eigene Farbe haben soll kannst du mit der item-id Klasse diese direkt ansprechen. zB so:
li.item-474 > a {
  background-color: lightgrey;
}
Ich denke das ist was du brauchst.

Wenn du zwischen zwei Farben abwechseln willst, kannst du auch sowas witziges wie das hier machen:
li.item-468 > ul > li:nth-child(odd) > a {
  background-color: lightgrey;
}
li.item-468 > ul > li:nth-child(even) > a {
  background-color: darkgrey;
}

Wenn du spezifische Fragen hast, kann ich dir gerne helfen :)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Jahre 23 Stunden her #1259 von Hotzenplotz
Vielen Dank für deine rasche Rückmeldung...

Leider klappt das nicht. Ich habe den Code in das Template bei den "Advanced Template Options" unter Custom CSS geschrieben und diese aktiviert. Leider sehe ich keinen Unterschied zu vorher.
Ich glaube, das System hat aber dafür eine neue CSS-Datei angelegt "template122.css" oder war die vorher schon da?

Was ich noch bräuchte wäre dass der Menüpunkt beim MouseOver nicht grau hinterlegt wird sondern fett dargestellt wird.

Sorry, dass ich solche Sachen frage, aber bislang musste ich solche Dinge noch nicht machen und habe da einfach noch gewisse Defizite, die ich hoffentlich durch solche Fragen weg bekomme ;) .

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Jahre 22 Stunden her #1260 von Thomas Hunziker
Gewisse Regeln gehen nicht wenn man sie in dem Feld eingibt. Das ist nen Bug im System den ich mal flicken sollte.
Versuchs wenn du die Regeln in eine /templates/lessallrounder/css/custom.css Datei schreibst. Dann sollten alle Regeln gehen.

Die CSS Datei mit der Nummer ist normal. Die wird erstellt sobald du den Stil das erste Mal speicherst.

Damit der Hintergrund beim drüberfahren (hover) "weiss" bleibt kannst du sowas nutzen:
.module_menu ul li a:hover {
  background-color: #f9f9f9;
}

Fett ists ja schon.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Jahre 22 Stunden her - 7 Jahre 22 Stunden her #1261 von Hotzenplotz
Meine Güte, du bist fix im Antworten...

Habe jetzt gerade das Problem, dass ich im Firefox vergeblich auf Speichern klicke, nachdem ich im Template gesagt habe, dass er Custom-CSS verwenden soll. Da tut sich gar nix.

Langsam nervt mich das, ich befürchte hier nämlich ein Problem mit dem Update von 2.5 auf 3.4.1 .

Zu Hause kann ich z.B. in der Konfiguration zwar was ändern, aber ebenfalls nicht speichern. Nur Abbrechen funktioniert.

Seltsamerweise hat das vorhin noch geklappt sonst hätte ich ja die template122.css nicht bekommen. Jetzt neu angemeldet und es geht nicht mehr :( . Im IE hat es jetzt geklappt, muss man nicht verstehen oder?

Jetzt ist der erste Menüpunkt rot hinterlegt, das mit dem hover hat nicht geklappt (soll die gleiche Farbe haben wie beim Aufruf des Menüs) und fett ist der Text auch nicht (im Standard) ;)
Letzte Änderung: 7 Jahre 22 Stunden her von Hotzenplotz.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Jahre 21 Stunden her #1262 von Thomas Hunziker
Den Firefox nutze ich schon lange nicht mehr. Aber ich kann mir nicht vorstellen dass das aktivieren eines Parameters das Speichern komplett verhindern wird. Das wird also eher ein anderes Problem sein.

Was nach Updates manchmal vorkommt ist dass etwas im Cache hängen bleibt. Versuch mal im Browser den Cache zu leeren, resp ein "hartes" Reload zu machen. Bei den meisten Browsern unter Windows kannst du das mit Ctrl-F5 machen.
Allenfalls auch im Joomla gucken ob da Caching aktiv ist.

Wenn beim Drücken des Knopfs immernoch gar nix passiert, deutet das auf einen javaScript Fehler hin. Den solltest du eigentlich in der Console deines Browsers (in den Developer Tools) sehen können.

Den Hover Effekt willst du beim roten Menüpunkt? Dann kannste das so machen:
li.item-474 > a {
  background-color: red;
}
li.item-474 > a:hover {
  background-color: red !important;
  font-weight: bold !important;
}

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.136 Sekunden
Powered by Kunena Forum
   
© Bakual