Template Variablen fehlen

Mehr
3 Monate 2 Wochen her #3768 von Ralf Schäfer
Ich habe heute das Problem bekommen, dass ich die template14.css nicht mehr bauen konnte.
Es wurden mehrere fehlende Variablen gemeldet, die ich dann nach und nach in die variables.less eingefügt bzw. dort auskommentiert habe:

Neu:
===
@minDesktopWidth: 100;
@maxMobileWidth: 600;

Auskommentiert:
===========
@linkColor: #08c;
@linkColorHover: darken(@linkColor, 15%);

Nun läßt sich das template14.css wieder erstellen.

Warum treten diese Fehler auf, hat das vielleicht etwas mit der neuen Joomla Version (3.8.7) zu tun?
Das Template hat übrigens die Version 2.5.1.

Welche Default Werte sollte man für minDesktopWidth und maxMobileWidth korrekterweise verwenden?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 2 Wochen her #3769 von Thomas Hunziker
Also bei mir funktioniert es tadellos, und ich wüsste auch von keiner Änderung in Joomla welche sowas generieren könnte.
In den LESS Dateien solltest du grundsätzlich auch nichts anpassen müssen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 2 Wochen her #3770 von Matthias
1. Ein Seitenlink hilft bei der Lösungsfindung. Es ist immer recht nervig, wenn man erst die älteren Beiträge eines Nutzers durchsuchen muss, damit man einen Link zu der von ihm möglicherweise thematisierten Seite findet.
2. Es ist keine gute Idee, Joomla in einem Frame anzuzeigen, da so weniger versierten Nutzern die Möglichkeit genommen wird, eine Referenz auf eine bestimmte Seite zu versenden/speichern. Außerdem erschwert es mir den Zugriff auf die Dateien deines Templates, da ich erst erkennen muss, das ein Frame genutzt wird.

Nun zum Problem:
Das Problem liegt in der custom.less. Am Anfang hatte ich für die mobile Darstellung der Seite eigene LESS-Variablen definiert. Nach einiger Zeit bin ich allerdings zu der Überzeugung gelangt, dass es günstiger wäre die Bootstrap-Variablen zu nutzen. Deshalb habe ich die alten Variablen entfernt. Wenn du nun in deiner custom.less @minDesktopWidth durch @navbarCollapseDesktopWidth und @maxMobileWidth durch @navbarCollapseWidth ersetzt, sollte alles wieder wie vorher funktionieren und die zusätzlichen Deklarationen in der variables.less sollten überflüssig sein.

Btw. @minDesktopWidth sollte @maxMobileWidth+1px sein. Als Defaultwert dient der Wert, der unter Mobiel view for im Backend definiert wurde.

Das auskommentieren von Variablen könnte zu weiteren Problemen führen, weshalb ich davon abrate.

Außerdem gehen Änderungen in der variables.less bei einem Update des Templates verloren.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 2 Wochen her #3778 von Ralf Schäfer
Vielen Dank für die schnelle Antwort!
Ich habe die custom.less wie beschrieben angepasst und die Seite funktioniert wieder fehlerfrei.
(Die Webseite "roesenbeck.de" habe ich in einen Frame gepackt, da auf dem Webspace 2 Homepages liegen und ich den Subfolder der ungern veröffentlichen möchte)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.094 Sekunden
Powered by Kunena Forum
   
© Bakual