Linkfarbe und Linkdecoration anpassen

Mehr
4 Monate 2 Tage her #3689 von Marc
Hallo,

ich habe Probleme in eigenen Modulklassen die Linkfarbe anzupassen:

Ich habe ein Modul auf die Bannerposition plaziert und dort einen Link auf den Internen Bereich angelegt.
Der Link soll die Headerfarbe haben und nicht unterstrichen sein.

Ich habe eine andere Modulklasse (die funktioniert) kopiert und angepasst.

#leftcol .link-blauer-font a {
font-size: 14px;
line-height: 20px;
color: #005ba9;
text-decoration: none;
}

für Bannerposition:

#banner .link-banner-gelber-font a, a:hover, a:visited {
font-size: 14px;
color: #feec00;
text-decoration: none;
}

Schonmal vielen Dank für die Hilfe.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 2 Tage her - 4 Monate 2 Tage her #3690 von Matthias
Mir ist folgendes an deinem Code aufgefallen:
  1. Nutze bitte die passende Formatierung, wenn du Code postet, das erleichtert das lesen.
  2. Einrückungen erleichtern das lesen zusätzlich.
  3. nach einem Komma muss der gesamte CSS-Pfad wiederholt werden:
    #banner .link-banner-gelber-font a,
    #banner .link-banner-gelber-font a:hover,
    #banner .link-banner-gelber-font a:visited {
        font-size: 14px;
        color: #feec00;
        text-decoration: none;
    }
    alternativ in der /less/custom.less oder /css/custom.css kann folgender LESS-Code genutzt werden:
    #banner .link-banner-gelber-font {
        a, a:hover, a:visited {
            font-size: 14px;
            color: #feec00;
            text-decoration: none;
        }
    }
    Hierbei ist die Verschachtelung wichtig, da so alle Teile an den des übergeordneten Blocks angehängt werden.
  4. Wenn ich nun noch einen Link zur Seite hätte, könnte ich dir auch sagen, wo genau das Problem liegt, und wie die Lösung aussieht. Denn ohne kann ich nicht ermitteln, welche Regeln stärker gewichtet werden und deshalb deine überschreiben.
Letzte Änderung: 4 Monate 2 Tage her von Matthias.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 1 Tag her #3691 von Marc
Hallo Matthias,

vielen Dank für deine Hilfe.
Ich habe meine Eingaben nochmals geprüft und festgestellt, dass ich ein Leerzeichen zuviel hatte.
Die Einstellungen funktionieren, aber leider nicht so wich es mir vorstelle.

Hier ist der Link zu der Seite: sv-gemmingen.de/svg_cms/

Ich wollte eigentlich nur den Link oben rechts "Interner Bereich" mittels gelber Farbe unsichtbar machen.

Derzeit habe ich in dem Modulklasensuffix mit dem Wort Fehler ...des Funktion ausgeschaltet, damit man die Seite anschauen kann. Wenn ich es aktiviere werden verschiedene Links gelb und das will ich ja eigentlich nicht.

Weiterhin habe ich mit der Erstellung einer custom.css Probleme und es funktioniert nicht.
Ich habe des Template lessAllrounder 2x installiert und nun denke ich, dass deshalb die customs.css nicht funktioniert. Habe mich jedoch nicht getraut, dass eine Template ohne vorherige Sicherung zu löschen.

Bitte schreib mir kurz, wenn du die Seite angeschaut hast, dann stelle ich mal auf die gelbe Linkfarbe um.

Schonmal vielen Dank für deine weitere Hilfe.
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 1 Tag her #3692 von Matthias
Da es sich um einen Modulklassensuffix handelt wird dieser direkt an die Standardklasse für eigene Module gehängt. Somit lautet die Klasse deines Moduls customlink-banner-gelber-font. Wenn man Klassen hinzufügen möchte, muss man davor ein Leerzeichen setzen.

Da der Header einen Verlauf hat, empfehle ich
    color: transparent;

Das setzen der Schriftgröße kannst du dir sparen, da du die generell auf 14px festgelegt hast.
Bei CSS muss nicht ein gesamter Block überschrieben werden. Es reicht nur die Zeilen mit den Änderungen zu überschreiben. Das dünnt deinen Code massiv aus und verbessert die Übersichtlichkeit.

Wie ich in meinem letzten Beitrag schon schrieb, muss nach einem Komma der gesamte CSS-Pfad wiederholt werden. Das dürfte dein Problem mit der Farbänderung in anderen Bereichen der Seite beheben.

Der CSS-Code ist nur deaktiviert, weil du ein Leerzeichen hinter dem # hast, wodurch der Browser die Verarbeitung abzubrechen scheint. Das Wort fehler_ ändert an der Funktion von a:hover, a:visited nämlich nichts.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 3 Wochen her #3701 von Marc
Hallo Matthias,
vielen Dank für deine Hilfe.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.100 Sekunden
Powered by Kunena Forum
   
© Bakual